Name:SELECTT
 
Version:1.7.0.3
 
Publisher:CMU
 
The following prerequisites are required:
 
  • Microsoft .NET Framework 4.7.2 (x86 and x64)
If these components are already installed, you can launch the application now.
 
 
CMU Customer Support    ::    ClickOnce and .NET Framework Resources